Python dependency conflict with gnome-music-3.10

If it happens to you that you hit the following dependency conflict with different python versions involved, like:

 # emerge -a1v gnome-music

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for media-sound/gnome-music
... done!

!!! The ebuild selected to satisfy "gnome-music" has unmet requirements.
- media-sound/gnome-music-3.10.1::gentoo USE="" PYTHON_SINGLE_TARGET="-python3_2 -python3_3" PYTHON_TARGETS="python3_3 -python3_2"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_2 python_single_target_python3_3 )

  The above constraints are a subset of the following complete expression:
    python_single_target_python3_2? ( python_targets_python3_2 ) python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_2 python_single_target_python3_3 )

while using the default python configuration:

$ emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.17, 3.10.7-gentoo x86_64)
...
PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3"
...

then this conflict can be temporarily resolved by adding a python_single_target_python3_3 USE flag to the corresponding ebuild:

$ cat /etc/portage/package.use/gnome-3.10
...
media-sound/gnome-music python_single_target_python3_3
...
Advertisements